Exporting GeoTIFF with NODATA Values

dcollinsdcollins Global Mapper UserPosts: 2
edited April 2010 in Elevation Data
Hi Mike,

I've been using Global Mapper v10.02 to export elevation data in the GeoTIFF format (both 16-bit and 32-bit), and I'm encountering a problem encoding NODATA values: I cannot find any TIFF tags in the exported GeoTIFF which identify the NODATA value.

Does Global Mapper support NODATA values in exported GeoTIFF files? If so, how does it identify those values?

Thanks,
Dave

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited March 2010
    Dave,

    Global Mapper writes out -32767 for all void values in elevation GeoTIFF exports. You can also use the min and max value tags to determine the range of valid elevations, and treat anything outside this range as invalid (Global Mapper does this).

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • dcollinsdcollins Global Mapper User Posts: 2
    edited March 2010
    Mike,

    Thanks very much for clarifying. You've told me exactly what I need to know.

    Thanks,
    Dave
  • zubenelgenubizubenelgenubi Global Mapper User Posts: 12
    edited April 2010
    Im not seeing any option in the Geotiff export option to set a valid min or max elevation?

    I am trying to read srtm .hgt files and to remove the cells with elevations of 0. Is this the best way to proceed?

    TIA
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited April 2010
    TIA,

    That option is on the Adjust Elevations tab of the Options dialog for the layer available from the Control Center. Just adjust the min/max range there, then do the export.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • aickedamrauaickedamrau Posts: 1
    HI, I just found this discussion...
    I have to export a real NaN to the GeoTiff instead the -32767 Value. Is this possible?

    Thanks,
    Aicke
Sign In or Register to comment.